hero image

VC custom grid problem

Home Forums WordPress Themes Megalith VC custom grid problem

Forums WordPress Themes Megalith VC custom grid problem

PLEASE NOTE A RECENT CHANGE:
The forum is read-only. Please submit any support request here.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • atomik
    Member
    Member
    #46840

    I try to create custom posts grid using VC Grid Builder.

    It works nice but when I use it to display posts in grid layout, it always displays everything in ONE column only. It doesn’t matter how many columns per row I select in Post Grid settings.

    I dug the net a lot but couldn’t find any solution. It looks like it is not bound to the theme because it works the same (with the same problem) in Twenty Fifteen.

    What should I do?

    Tom


    Anonymous
    Inactive
    Inactive
    #46996

    Hi Tom,

    Sorry for a big delay.

    Please advise us with a page link where you put your custom Grid shortcode if a problem still persist.

    Kind regards, Michael.


    atomik
    Member
    Member
    #46999

    Hi Michael,

    Folloowing you have a link

    link

    It is not so hard to reproduce this error because it occurs in ANY installation I’ve got. I don’t think it is my problem only. I am sure it’s goona happen in your installation as well.

    What you can find under above link is Masonry Grid: Default saved as custom layout in VC. No changes at all.

    As I said, it displays one column only but is set to be displayed in 3 columns.

    Where is the problem?


    Anonymous
    Inactive
    Inactive
    #47028

    Hi Tom,

    We have inspected your Custom grid and seems that you have left some spaces between shortcodes, and they render into paragraphs. remove all spaces/new lines/etc. and this will solve your problem.

    Kind regards, Michael


    atomik
    Member
    Member
    #47046

    I would be glad if I could do it. How can I possibly do it? This is VC generating those 2 additional paragraphs..they do not exist when I use default templates but appear in any custom template.. or maybe I am missing something?

    Attached you have screenshot of that page backend. You can clearly see, that there is nothing but one block there.

    How can I remove these lines?


    Anonymous
    Inactive
    Inactive
    #47049

    Hello ,

    Please send your WP (WP installation url, WP username, WP password) and FTP (FTP host , FTP username, FTP password and optional: FTP port) credentials as a reply to the email you just got from us that contains this thread. This message will be kept private and only TeslaThemes support staff will see it . Once we get them , your issue will be resolved much quicker .
    Thanks for understanding.

    Regards.


    atomik
    Member
    Member
    #47052

    I’m bored with your “Please send your WP..” this is not the way it should be. You can EASLY generate this problem in ANY installation.

    Short instruction:

    • create new page with Post Grid element only and default settings,
    • edit Post Grid settings and select some category for “Narrow data source”
    • save and view page

    you will see, that all is fine and posts display in 3 columns

    • now edit that post an Post Grid settings > Item Design
    • click “modify selected”
    • it opens Grid Builder
    • create new grid template using Basic Grid: Default template
    • do not change anything just save using some name
    • go back to the page editor and Post Grid settings > Item Design, select created custom template and save

    When you view that page, you’ll see, that it displays one column (because of those 2 additional paragraphs).
    It shouldn’t because there is nothing additional, just a copy of default template.


    Anonymous
    Inactive
    Inactive
    #47308

    Okay, than please wait for the theme update that will fix the issue.
    Our developer is already working for it.


    atomik
    Member
    Member
    #47313

    Okay..

    I’m waiting forward to see your upgrade. Or better you ask WPBakery why there is that additional string present so they remove it and you do not have any job to do.

    I would ask them myself but unfortunately I’m not the license holder (you are).

    Tom

Viewing 9 posts - 1 through 9 (of 9 total)

VC custom grid problem

Home Forums WordPress Themes Megalith VC custom grid problem

[i]
[i]
[i]
[i]